Back to overview
Degraded

Email deliverability issue

Feb 24 at 08:14am GMT-3
Affected services
Application

Resolved
Feb 24 at 08:15am GMT-3

The team put remediation steps in place and is currently prioritizing long term adjustments to improve email deliverability.

Created
Feb 24 at 08:14am GMT-3

We are aware of issues receiving emails to multiple mailboxes.
The emails are currently being deferred by several minutes.
Our team is actively working on a resulting and we will keep you updated shortly.